본문내용 바로가기 메인메뉴 바로가기

하단내용 바로가기

취약점 정보

CVE-2019-12806 | UniSign 버퍼 오버플로우 취약점2019.08.13

□ 개요

 o  CROSSCERT의 UniSign에서 발생하는 버퍼 오버플로우 취약점

취약점 종류

영향

심각도

CVE ID

버퍼 오버플로우

코드실행

HIGH

CVE-2019-12806

 

□ 설명

 o UniSign의 특정 라이브러리에서 발생하는 스택 기반 버퍼 오버플로우 취약점으로, 특수하게 조작된 HTTPS 패킷을 전송하여 임의 코드를 실행할 수 있음
 o 공격자는 이용자를 조작된 웹 페이지로 접속하도록 유도하여 악성코드 감염 등을 발생시킬 수 있음


□ 영향받는 제품

제품

버전

환경

UniSign

2.0.4.0 및 이전버전

윈도우


□ 해결 방안

 o 취약점이 해결된 최신 보안 패치(2.0.5.0 및 이상 버전)으로 업데이트 적용

 

□ 참고 사이트

https://www.unisign.co.kr/

 

□ Credit
 o 해당 취약점은 KrCERT 홈페이지를 통해 고기완님께서 제공해주셨습니다.