본문내용 바로가기 메인메뉴 바로가기

하단내용 바로가기

취약점 정보

CVE-2019-12807 | 알집 ISO 압축 포맷 버퍼 오버플로우 취약점2019.08.13

□ 개요

 o 이스트소프트社 알집 프로그램의 ISO 압축 포맷 라이브러리에서 스택 오버플로우로 인한 원격 코드 실행 취약점

취약점 종류

영향

심각도

CVE ID

버퍼 오버플로우

코드실행

HIGH

CVE-2019-12807

 

□ 설명

 o 알집(Alzip)이 ISO 압축 파일을 해제할 때 입력 받은 데이터에 대한 버퍼 길이 검증이 미흡하여 스택 메모리 데이터 변조를 통해 임의 코드를 실행할 수 있음
 o 공격자는 조작된 파일을 압축 해제하도록 유도하여 악성코드 감염 등을 발생시킬 수 있음


□ 영향받는 제품

제품

버전

환경

알집(Alzip)

10.83 및 이전버전

윈도우


□ 해결 방안

 o 취약점이 해결된 최신 보안 패치(10.85 및 이상 버전)으로 업데이트 적용

 

□ 참고 사이트

https://www.altools.co.kr/Download/ALZip.aspx

 

□ Credit
 o 해당 취약점은 KrCERT 홈페이지를 통해 고항준님께서 제공해주셨습니다.