본문내용 바로가기 메인메뉴 바로가기 하단내용 바로가기

보안공지

보안공지 상세보기
OpenSSL 취약점 보안업데이트 권고2015.12.08
□ 개요
   o OpenSSL에서는 서비스 거부 공격 취약점, Race condition 취약점 등 5개의 취약점을 보완한 보안업데이트를 발표[1]
 
□ 설명
   o NB_mod_exp 함수에서 값을 제곱 처리 할 때 발생하는 취약점 (CVE-2015-3193)
   o 인증서 검증시 PSS 파라미터 부재로 인한 서비스 거부 취약점 (CVE-2015-3194)
   o X509_ATTRIBUTE 구조체에서 발생하는 OpenSSL 메모리 누수 취약점 (CVE-2015-3195)
   o PSK Identify hint 처리 중 발생하는 Race condition 취약점 (CVE-2015-3196)
   o ServerKyExchange의 값을 처리 중에 발생하는 서비스 거부 공격 취약점 (CVE-2015-1794)
 
□ 해당 시스템
   o 영향 받는 제품 및 버전
    - OpenSSL 1.0.2
    - OpenSSL 1.0.1
    - OpenSSL 1.0.0
    - OpenSSL 0.9.8 
 
□ 해결 방안
   o 해당 취약점에 영향 받는 버전의 사용자는 아래 버전으로 업데이트[2]
    - OpenSSL 1.0.2 사용자 : 1.0.2e로 업데이트
    - OpenSSL 1.0.1 사용자 : 1.0.1q로 업데이트
    - OpenSSL 1.0.0 사용자 : 1.0.0t로 업데이트
    - OpenSSL 0.9.8 사용자 : 0.9.8zh로 업데이트
 
□ 기타 문의사항
   o 한국인터넷진흥원 인터넷침해대응센터: 국번없이 118
 
[참고사이트]
[1] https://www.openssl.org/news/secadv/20151203.txt
[2] https://www.openssl.org/
키워드 OpenSSL , 보안업데이트 , 취약점