본문내용 바로가기 메인메뉴 바로가기

하단내용 바로가기

보안공지

Adobe Flash Player 신규 취약점 보안 업데이트 권고2016.04.08
□ 개요
 o Adobe社는 Flash Player에서 발생하는 취약점을 해결한 보안 업데이트를 발표[1]
 o 낮은 버전 사용자는 악성코드 감염에 취약할 수 있으므로 해결방안에 따라 최신버전으로 업데이트 권고
 
□ 설명
 o Adobe Flash Player의 24개 취약점에 대한 보안 업데이트를 발표[1]
   · JIT 스프레잉 공격을 통해 메모리 보호기법을 우회할 수 있는 취약점(CVE-2016-1006)
   · 임의코드 실행으로 이어질 수 있는 Type confusion 취약점(CVE-2016-1015, CVE-2016-1019)
   · 임의코드 실행으로 이어질 수 있는 Use-Ater-Free 취약점(CVE-2016-1011, CVE-2016-1013, CVE-2016-1016,
      CVE-2016-1017, CVE-2016-1031)
   · 임의코드 실행으로 이어질 수 있는 메모리 손상 취약점(CVE-2016-1012, CVE-2016-1020, CVE-2016-1021,
      CVE-2016-1022, CVE-2016-1023, CVE-2016-1024, CVE-2016-1025, CVE-2016-1026, CVE-2016-1027,
      CVE-2016-1028, CVE-2016-1029, CVE-2016-1032, CVE-2016-1033)
   · 임의코드 실행으로 이어질 수 있는 스택 오버플로우 취약점(CVE-2016-1018)
   · 기존에 패치된 취약점에 대한 보안 우회 취약점(CVE-2016-1030)
   · 디렉토리 검색 경로가 취약하여 임의코드 실행이 가능한 취약점(CVE-2016-1014)
 
□ 영향 받는 소프트웨어
 o Adobe Flash Player
소프트웨어 명 동작환경 영향 받는 버전
Adobe Flash Player Desktop Runtime 윈도우즈, 맥 21.0.0.197 및 이전버전
Adobe Flash Player Extended Support Release 윈도우즈, 맥 18.0.0.333 및 이전버전
Adobe Flash Player for Google Chrome 윈도우즈, 맥, Linux, ChromeOS 21.0.0.197 및 이전버전
Adobe Flash Player for Microsoft Edge
and Internet Explorer 11
Windows 10 21.0.0.197 및 이전버전
Adobe Flash Player for Internet Explorer 11 Windows 8.1 21.0.0.197 및 이전버전
Adobe Flash Player for Linux Linux 11.2.202.577 및 이전버전
 
□ 해결 방안
 o Adobe Flash Player 사용자
   - 윈도우즈, 맥 환경의 Adobe Flash Player desktop runtime 사용자는 21.0.0.213 버전으로 업데이트 적용
   - Adobe Flash Player Extended Support Release 사용자는 18.0.0.343 버전으로 업데이트 적용
   - 리눅스 환경의 Adobe Flash Player 사용자는 11.2.202.616 버전으로 업데이트 적용
   - Windows 10 및 Windows 8.1에서 Microsoft Edge 또는 Internet Explorer 11를 사용중인 사용자는 MS 4월 정기 보안업데이트 시
      최신 업데이트가 적용
     · 그 외 사용자는 Adobe Flash Player Download Center(http://www.adobe.com/go/getflash)에 방문하여 최신 버전 설치,
        자동 업데이트를 이용하여 업그레이드  
 
□ 용어 정리
 o Use-After-Free 취약점 : 소프트웨어 구현 시 동적 혹은 정적으로 할당된 메모리를 해제했음에도 불구하고 이를 계속 참조(사용)하여 
    발생하는 취약점
 
□ 기타 문의사항
 o 한국인터넷진흥원 인터넷침해대응센터: 국번없이 118
 
[참고사이트]
[1] https://helpx.adobe.com/security/products/flash-player/apsb16-10.html
키워드 Adobe , Flash Player , 취약점