본문내용 바로가기 메인메뉴 바로가기 하단내용 바로가기

보안공지

Apache Struts 2 취약점 보안 업데이트 권고2018.08.23
□ 개요
 o Apache Struts에서 원격코드 실행 취약점을 해결한 보안 업데이트 발표 [1]
 o 낮은 버전을 사용 중인 시스템은 악성코드 감염에 취약할 수 있으므로, 최신 버전으로 업데이트 권고
 
□ 설명
 o Struts 프레임워크의 코어에서 사용자의 데이터에 대한 검증이 미흡하여 발생하는 원격코드 실행 취약점(CVE-2018-11776) [2]

□ 영향을 받는 제품
 o Struts 2.3 ~ 2.3.34 버전
 o Struts 2.5 ~ 2.5.16 버전

□ 해결 방안
 o Struts 2.3 ~ 2.3.34 버전 사용자
  - 해당 사이트[3]를 참고하여 2.3.35 버전으로 업데이트 적용
 o Struts 2.5 ~ 2.5.16 버전 사용자
  - 해당 사이트[3]를 참고하여 2.5.17 버전으로 업데이트 적용

□ 기타 문의사항
 o 한국인터넷진흥원 인터넷침해대응센터: 국번없이 118

[참고사이트]
[1] https://cwiki.apache.org/confluence/display/WW/S2-057
[2] https://nvd.nist.gov/vuln/detail/CVE-2018-11776
[3] https://struts.apache.org/download.cgi