본문내용 바로가기 메인메뉴 바로가기 하단내용 바로가기

보안공지

보안공지 상세보기
Adobe ColdFusion 보안 업데이트 권고2018.11.15

□ 개요

 o Adobe社의 ColdFusion을 낮은 버전으로 사용 시 원격코드실행 등이 가능한 취약점 존재[1]
 o 공격자는 해당 취약점을 악용하여 악성코드 감염 등의 피해를 발생시킬 수 있으므로 이용자들은 아래 해결 방안에 따른 조치 권고
  ※ 지난 9월 패치 파일이 공개되었으나, 미 조치된 시스템을 대상으로 실제 침해사고에 악용된 사례가 있으므로 이용자들의 각별한 주의와 적극적인 대처 필요

□ 설명
 o 신뢰할 수 없는 데이터를 역직렬화하여 발생하는 임의코드실행 취약점(CVE-2018-15957, 15958, 15959, 15965)
 o 취약한 컴포넌트를 이용하여 임의파일을 덮어씌을 수 있는 취약점(CVE-2018-15960)
 o 임의 파일을 업로드하여 코드실행이 가능한 임의코드실행 취약점(CVE-2018-15961)
 o 파일목록이 노출되는 정보노출 취약점(CVE-2018-15962)
 o 보안 기능을 우회하여 임의 폴더를 만들 수 있는 취약점(CVE-2018-15963)
 o 취약한 컴포넌트를 사용하여 발생하는 정보노출 취약점(CVE-2018-15964)

□ 영향을 받는 제품
 o ColdFusion (2018 release)

  - 2018.0.0.310739 버전 (7월12일 공개버전)

 o ColdFusion (2016 release)
  - ColdFusion Update 6 및 이전 버전
 o ColdFusion 11
  - ColdFusion Update 14 및 이전 버전


□ 해결 방안

 o 영향받는 제품일 경우, 참고사이트를 확인하여 업데이트 버전으로 패치
  - ColdFusion (2018 release) [2]
  - ColdFusion (2016 release) [3]
  - ColdFusion 11 [4]

□ 용어 설명
 o ColdFusion : 웹사이트나 인트라넷에서 데이터처리를 위해 사용되는 RAD 플랫폼

□ 기타 문의사항
 o 한국인터넷진흥원 인터넷침해대응센터: 국번없이 118

 

[참고사이트]

[1] https://helpx.adobe.com/kr/security/products/coldfusion/apsb18-33.html

[2] https://helpx.adobe.com/coldfusion/kb/coldfusion-2018-update-1.html

[3] https://helpx.adobe.com/coldfusion/kb/coldfusion-2016-update-7.html

[4] https://helpx.adobe.com/coldfusion/kb/coldfusion-11-update-15.html