본문내용 바로가기 메인메뉴 바로가기

하단내용 바로가기

보안공지

리눅스 패키지 매니저 APT 원격코드실행 보안 업데이트 권고2019.01.23

□ 개요

 o 리눅스 운영체제에서 응용 SW 설치 또는 업데이트를 위해 사용하는 패키지 매니저(APT)에서 원격코드실행 취약점이 발견

    ※ APT(Advanced Packaging Tool) : 응용 프로그램 설치, 업데이트, 업그레이드를 수행하는 리눅스 패키지 매니저

 o 영향 받는 버전을 사용 중인 이용자는 해결 방안에 따라 최신 버전으로 업데이트 권고

 

□ 설명

  o APT 패키지 매니저의 HTTP 리다이렉션 패킷을 중간에서 가로채어 의도하지 않은 악성 컨텐츠를 삽입할 수 있는 취약점

     (CVE-2019-3462)


□ 영향 받는 버전

  o 데비안

    - APT 버전 < 1.4.9

  o 우분투

    - Ubuntu 12.04, 14.04, 16.04, 18.04, 18.10에 설치된 APT 파일

 

□ 해결 방안

 o 최신 보안 업데이트 적용

   - 아래 OS별 참고사이트에 접속하여 최신 버전으로 APT 보안 업데이트 수행

  o 보안 업데이트가 불가능한 경우 아래와 같이 설정

    · $ sudo apt update -o Acquire::http::AllowRedirect=false

    · $ sudo apt upgrade -o Acquire::http::AllowRedirect=false

 

□ 기타 문의사항

 o 한국인터넷진흥원 인터넷침해대응센터: 국번없이 118

 

[참고사이트]

<데비안> https://security-tracker.debian.org/tracker/CVE-2019-3462

<우분투>

   (1) https://usn.ubuntu.com/3863-1/

   (2) https://usn.ubuntu.com/3863-2/