본문내용 바로가기 메인메뉴 바로가기

하단내용 바로가기

보안공지

PHP 다중 취약점 보안 업데이트 권고2019.09.11

□ 개요

 o PHP Group은 다수의 보안 취약점을 해결한 보안 업데이트 발표 [1]

 o 공격자는 해당 취약점을 이용하여 임의코드 실행 등 피해를 발생시킬 수 있으므로, 해당 제품을 사용하는 이용자들은 최신 버전으로 업데이트 권고

 

□ 주요 내용

 o PHP의 특정 함수의 입력값 검증 미흡으로 정보노출 및 use-after-free 취약점 발생(CVE-2019-13224)

 o PHP의 특정 함수에서 파일 검증 미흡으로 발생하는 정보노출 취약점(CVE-2019-11040 외 다중 취약점)

 o PHP의 특정 함수에서 MIME 헤더를 파싱 시 오버플로우 발생으로 정보노출 가능 취약점(CVE-2019-11039)

 o PHP의 특정 함수를 통해 메모리에 저장된 값을 읽고 쓰기가 가능한 취약점(CVE-2019-9025)

 o PHP의 특정 함수에서 입력값 검증이 미흡하여 임의의 메모리 주소에 접근 가능한 취약점(CVE-2019-9020)

 

□ 영향을 받는 제품

 o PHP 7.1 ~ 7.1.32 이전 버전

 o PHP 7.2 ~ 7.2.22 이전 버전

 o PHP 7.3 ~ 7.3.9 이전 버전

 

□ 해결 방안

 o PHP 공식 홈페이지를 참고하여 최신 버전으로 업데이트 수행 [2]

  - PHP 7.1.32 버전

  - PHP 7.2.22 버전

  - PHP 7.3.9 버전

 

□ 기타 문의사항

 o 한국인터넷진흥원 인터넷침해대응센터: 국번없이 118

 

[참고사이트]

[1] https://www.php.net/ChangeLog-7.php

[2] https://www.php.net/downloads.php