본문내용 바로가기 메인메뉴 바로가기 하단내용 바로가기

보안공지

OpenSSL 취약점 보안 업데이트 권고2020.04.23

□ 개요

 o OpenSSL에서 발생하는 취약점을 해결한 보안 업데이트 발표[1]

 o 낮은 버전 사용자는 서비스 거부 공격에 취약하므로, 최신 버전으로 업데이트 권고

 

□ 설명

 o 핸드 쉐이킹 과정에서 유효하지 않은 서명 알고리즘(signature algorithm)을 처리할 때 널 포인터 역참조로 인해 크래시가 발생하는 서비스 거부 취약점(CVE-2020-1967)

 

□ 영향을 받는 제품

 o OpenSSL 1.1.1d 버전

 o OpenSSL 1.1.1e 버전

 o OpenSSL 1.1.1f 버전

 ※ 1.1.1d 이전 버전은 영향 받지 않음

 

□ 해결 방안

 o 영향받는 사용자는 최신버전으로 업데이트 적용

  - OpenSSL 1.1.1g 버전으로 업데이트 적용 

 

□ 기타 문의사항

 o 한국인터넷진흥원 사이버민원센터: 국번없이 118

 

[참고사이트]

[1] https://www.openssl.org/news/secadv/20200421.txt

[2] https://www.openssl.org/source/




□ 작성 : 침해사고분석단 취약점분석팀